Supported Frameworks

Java/Scala

ShiftLeft is compatible with Java applications, including those that use the following frameworks.

Framework

Supported Versions

Notes

Akka (Java API)

2.5.x

Akka (Scala API)

2.5.x

Dropwizard

1.x, 2.x

Eclipse Vert.x

3.x

Google Web Toolkit (GWT)

2.8.x

Java Servlets

3.x

JAX-RS

1.x, 2.x

JAX-WS

2.x

JSF

2.x

Play (Java API)

2.4.x, 2.5.x, 2.6.x, 2.7.x

Play (Scala API)

2.5.x, 2.6.x, 2.7.x

Spark

2.7.x, 2.8.x, 2.9.x

Refers to the micro web framework, not the Apache Spark project

Spring MVC

3.x, 4.x, 5.x

Spring WebFlux

5.x

Struts

2.x

Struts XWork2

2.x

Other Frameworks/Versions

If you are using a framework (or a different version from the ones listed above), it's possible that it may be compatible with ShiftLeft. Please contact us for additional details.